3

I recently purchased LLPSI on Google Play Books; I already own it as a kindle book, but Google had a bundle that included Pars II and a companion book. Unfortunately, I can't get it to load in Safari, Chrome, or FireFox in mac OS Catalina. Does it work in a browser for anyone else? Did anyone else have this problem, and if so, how did you fix it? I've tried clearing my browser cache and cookies in all three browsers and also made sure that I wasn't blocking third party cookies.

It's this ad infinitum:

enter image description here

Note that it while it will load in iOS on my iPhone, it will sometimes get stuck loading there as well. Unlike in browsers, though, I can quit the iOS app, reopen it, and it then loads.

Edit: I posted this here in the event anyone else is using this book as a resource to learn Latin and has or will be getting it from Google Play. I have a support ticket in with Google, but thought I'd post about it here anyway.

3

I've yet to get a resolution from Google as it's basically been a lot of asking redundant information, and telling me to submit a new ticket instead of escalating my current one.

That said, I tried downloading the PDF version of the book from my play library (click on the three vertical dots when you hover over the book). This PDF only works with Adobe Digital Edition (which is free), but it works correctly and will let you read the book on your Mac or Windows PC.

Edit: I installed the play books Chrome app into Chrome and this also works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.